RELÓGIO CONTROLADOR PROGRAMÁVEL MULTICANAIS II – COM PIC 16F628A E DS1302 (REF186)  

  RSS

0

Boa noite Claudio, tentei montar o projeto do RELÓGIO CONTROLADOR PROGRAMÁVEL MULTICANAIS II – COM PIC 16F628A E DS1302 (REF186), só  que não funciona direito, no display no lugar das horas em alguns caracteres aparece pontos de interrogação. Consigo acertar a hora, data e  o tempo de ligado e desligado porem quando termina de ajustar da esse erro! O que pode ser? fazendo isso pra minha esposa rsrsrs, irrigação das plantinhas dela. Fiz um video curtinho no display estou enviando junto. Testei no proteus e deu o mesmo erro. Abraço

 
0

Você está usando bateria de 3 volts no pino 8 do DS1302?  Se não estiver, conecte uma bateria de 3 v ao gnd. Se não tem uma tente conectar o pino 8 ao gnd por meio de um resistor de baixo valor (470 ohms) e veja se resolve o problema. Também confira o valor dos resistores de pull up de 4k7 nos pinos 5 e 6. Se necessário, substitua eles por um valor menor como  2k2.

 
0

Bom dia Claudio, estou usando uma bateria sim, comprei aqueles módulos do mercado livre que já vem com soquete e cristal ! Será que são confiáveis?? fiz o procedimento que me passou mas não deu certo! Vou comprar um ds1302 em um outro fornecedor pra testar. Teve um momento que tirei a bateria ele ajustou a hora e data e funcionou certo, mas fiz um teste desliguei e fui ajustar a hora e data novamente e deu o erro. Engraçado que no simulador também da esse erro, aparece nos segundos um 7 com ponto de interrogação, e os minutos mudam rapidamente! O que pode ser? 

Abraço!

 
0

Ola Claudio, fazendo uns testes de ajuste, verifiquei que se eu ajustar hora e data apertar o menu para mudar para o ajuste do canal ele vai para o canal1 e em seguida apertar o reset ele grava a hora e data normal! ao contrario se você continuar ajustando os canais ele da esse erro. Não sei se é isso mas parece que quando vc acerta o hora e data e aperta o menu para ajustar os canais não esta gravando os dados. Desculpe se falei besteira!

Abraço

 
0

Você está usando qual versão? De 7 canais?

Eu montei de novo o circuito no protoboard e usei o hex para 7 canais que baixei do próprio site. Não encontrei problema no funcionamento. Tudo normal. Posso ajustar hora/minuto/segundo/ dia da semana/ data e prosseguir ajustando canais que grava normalmente.  Estou usando um ci DS1302 separado e não um módulo.  Verifique as ligações se estão de acordo com o esquema. Confira a tensão da bateria de 3v3 e a tensão de 5 volts. Verifique se colocou o resistor de 10 k ao vcc no pino 4 do pic. Também observe que no esquema tem um resistor de 4k7 no rst (reset pino 5 do DS1302) e outro de 4k7 na linha de dados (pino 6 do DS1302).  A falta deles podem causar perturbações no funcionamento. Precisa verificar se dentro do seu módulo estes resistores já existem ou não.

 
0

Ola Claudio, usei a versão de 4 canais, vou gravar essa versão de 7 canais e testar. O módulo não possui os resistores, coloquei eles na placa, pinos 5 e 6 respectivamente. A bateria esta com os 3,3v e o  5v estão corretos. Como disse vou gravar essa versão de 7 canais pra testar e volto com os resultados encontrados.

Obrigado pelo retorno!

 
0

Bom dia Claudio, testei aqui a versão 7  e apresentou o mesmo erro, pedi um ds1302 pra testar, acredito que seja ele oproblema, mas da pra usar na boa, só apertar o o menu e quando entrar para ajustar o primeiro canal apertar o reset e fica tudo certo. estou tendo problema com aquele projeto que vc esta me ajudando mas vou fazer o comentário la ok?

Abraço!!

 
0

Boa noite Claudio, chegou meu outro DS1302 e realmente era ele o problema mesmo. Troquei e tudo certo!!

Obrigado novamente, forte abraço!

Que bom que finalmente encontrou a raiz do problema e obteve a solução. Realmente, certos componentes duvidosos geram muita dor de cabeça para quem é hobista. 

Parabéns  por sua determinação!

Share: